No signal on Waveshare 5" (A), Waveshare 5" (B), 4K TV, 1080P TV

I am using the Desktop Preview Image 4 posted here. Red and green lights are on and blue is flashing. I'm using a 2A power supply. I have purchased 2 of these boards so far and had really put a lot of hope in them. I needed to use them primarily with the Waveshare 5" to make a pocket device. Is there anything I can try?

Comments

  • I cannot seem to edit my posts so I will post an update. I got the 11-08 image to work on the 4K TV and the 1080P TV. I have not gotten either image to work with the following Waveshare screens: 5" Waveshare HDMI (A), 5" Waveshare HDMI (B), old 7" HDMI Waveshare, 4" Waveshare HDMI. I have also seen from this forum that the new 1024x600 (marketed as 720P) Waveshare 7" does not work either. So that just about covers all Waveshare screens. Very disappointing that these popular screens and their clones all do not work.

  • I tried the Libreelec image posted here because as someone else mentioned it has a boot.ini with several HDMI resolution options. I tried the most relevant options (480I, 480P, 480P projection, 576P, 720P, and the default 1080P both with and without CEC turned on with the Waveshare 5" screen A. All options failed and nothing or garbage was displayed on the screen.

    Please provide some input as I am out of options.

  • I tried the Armbian server and desktop images and they also did not work with the Waveshare. I will also be on the #librecomputer IRC channel waiting for help for the next couple of days until I can get an O-Droid shipped to me.

  • @Jason_25, We haven't touched on non-edid displays or displays that use the DVI over HDMI protocol yet. We will source a couple of screens and do the testing.

  • I sure appreciate that. I will hold on to my boards in the meantime. I would like to produce who knows how many devices with this board and the Waveshare screens.

  • @loverpi to clarify the point with EDID: the 7 inch waveshare display I told about earlier has (as far as I know) EDID data, but only one supported resolution (1024x600). Maybe the problem is, that this resolution is non-standard and because of that not implemented yet in your software.

Sign In or Register to comment.