XUbuntu 16.04 Mainline Linux 4.14.11 Preview Image 7

edited January 20 in AML-S905X-CC

Hi @loverpi,
XUbuntu starts properly and prompt the login.
I cannot go further because the USB seems to not work. The keyboard is not working even the ver-num LED stay off.
My power supply is an official raspberry pi 2,5A
The same keyboard was working properly with Android images and Armbian (Armbian_5.34_Lepotato_Ubuntu_xenial_next_4.13.8_desktop).

Link of the img: https://www.kickstarter.com/projects/librecomputer/libre-computer-board-next-gen-4k-sbc-dev-board-for/posts/2085219

BR,
Antony

Comments

  • I have to unplug my wifi usb doggle 1st or can't type in login

  • I'm finding this image to be pretty unusable. I only got video output to a Toshiba TV once, otherwise it gets no signal. USB wifi dongle works, but can't even get a basic mouse and keyboard recognized. USB and video both work fine on either the LibreElec or Lakka images. Still waiting on this board to be useful...

  • edited January 24

    Can you provide the output for "dmesg -w" when you plug in the device? and "dmesg | grep -i usb". Also specify exactly which devices you have plugged into which port. It helps us duplicate the issue.

  • I would like to help but I cannot type anything without a keyboard. I tried 4 different keyboards.
    Nothing at all is recognise on USB ports

  • libre@libre-computer:~$ dmesg | grep -i usb                                     
    [    1.404188] usbcore: registered new interface driver usbfs                   
    [    1.404232] usbcore: registered new interface driver hub                     
    [    1.404305] usbcore: registered new device driver usb                        
    [    2.464792] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver       
    [    2.492092] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver           
    [    2.517263] xhci-hcd xhci-hcd.0.auto: new USB bus registered, assigned bus number 1                                                                          
    [    2.539821] hub 1-0:1.0: USB hub found                                       
    [    2.552436] xhci-hcd xhci-hcd.0.auto: new USB bus registered, assigned bus number 2                                                                          
    [    2.560067] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.                                                                     
    [    2.568462] hub 2-0:1.0: USB hub found                                       
    [    2.579300] usbcore: registered new interface driver usb-storage             
    [    2.659741] usbcore: registered new interface driver usbhid                  
    [    2.659744] usbhid: USB HID core driver                                      
    [    2.887119] usb 1-1: new high-speed USB device number 2 using xhci-hcd       
    [    3.072632] hub 1-1:1.0: USB hub found                                       
    

    plugin keyboard - top left port

    [  150.879166] usb 1-2: new low-speed USB device number 3 using xhci-hcd        
    [  161.271170] xhci-hcd xhci-hcd.0.auto: xHCI host controller not responding, assume dead                                                                       
    [  161.273537] xhci-hcd xhci-hcd.0.auto: HC died; cleaning up                   
    [  161.279160] usb usb1-port2: couldn't allocate usb_device                     
    [  161.246947] xhci-hcd xhci-hcd.0.auto: xHCI host not responding to stop endpoint command.                                                                     
    [  161.271170] xhci-hcd xhci-hcd.0.auto: xHCI host controller not responding, assume dead                                                                       
    [  161.273537] xhci-hcd xhci-hcd.0.auto: HC died; cleaning up                   
    [  161.279160] usb usb1-port2: couldn't allocate usb_device                     
    [  161.284430] usb 1-1: USB disconnect, device number 2                         
    

    remove keyboard, no messages
    plugin keyboard to any port, no messages

    reboot

    plugin hp rollerball mouse - bottom left port

    [   38.554928] usb 1-1.1: new low-speed USB device number 3 using xhci-hcd      
    [   38.701956] input: Logitech USB Mouse as /devices/platform/soc/c9000000.usb/xhci-hcd.0.auto/usb1/1-1/1-1.1/1-1.1:1.0/0003:046D:C001.0001/input/input1        
    [   38.702138] hid-generic 0003:046D:C001.0001: input: USB HID v1.10 Mouse [Logitech USB Mouse] on usb-xhci-hcd.0.auto-1.1/input0
    

    remove

    [  100.865526] usb 1-1.1: USB disconnect, device number 3                       
    

    re-plugin - top left port

    [  119.867230] usb 1-2: new low-speed USB device number 4 using xhci-hcd        
    [  130.033588] xhci-hcd xhci-hcd.0.auto: xHCI host controller not responding, assume dead                                                                       
    [  130.035875] xhci-hcd xhci-hcd.0.auto: HC died; cleaning up                   
    [  130.041391] usb usb1-port2: couldn't allocate usb_device                    
    [  130.014907] xhci-hcd xhci-hcd.0.auto: xHCI host not responding to stop endpoint command.                                                                      
    [  130.033584] xhci-hcd xhci-hcd.0.auto: Host halt failed, -110                 
    [  130.033588] xhci-hcd xhci-hcd.0.auto: xHCI host controller not responding, assume dead                                                                       
    [  130.035875] xhci-hcd xhci-hcd.0.auto: HC died; cleaning up                   
    [  130.041391] usb usb1-port2: couldn't allocate usb_device                     
    [  130.046664] usb 1-1: USB disconnect, device number 2 
    

    all ports dead again

    reboot

    retry keyboard - bottom left port

    [   52.871127] usb 1-1.1: new low-speed USB device number 3 using xhci-hcd      
    [   52.996137] input:   USB Multimedia Keyboard  as /devices/platform/soc/c9000000.usb/xhci-hcd.0.auto/usb1/1-1/1-1.1/1-1.1:1.0/0003:099A:610C.0001/input/input1
    [   53.055402] hid-generic 0003:099A:610C.0001: input: USB HID v1.00 Keyboard [  USB Multimedia Keyboard ] on usb-xhci-hcd.0.auto-1.1/input0                    
    [   53.059779] input:   USB Multimedia Keyboard  as /devices/platform/soc/c9000000.usb/xhci-hcd.0.auto/usb1/1-1/1-1.1/1-1.1:1.1/0003:099A:610C.0002/input/input2
    [   53.119074] hid-generic 0003:099A:610C.0002: input: USB HID v1.00 Device [  USB Multimedia Keyboard ] on usb-xhci-hcd.0.auto-1.1/input1                      
    

    unplug

    [  110.337535] usb 1-1.1: USB disconnect, device number 3     
    

    replug keyboard - bottom right port

    [  149.874967] usb 1-1.2: new low-speed USB device number 4 using xhci-hcd      
    [  149.987727] input:   USB Multimedia Keyboard  as /devices/platform/soc/c9000000.usb/xhci-hcd.0.auto/usb1/1-1/1-1.2/1-1.2:1.0/0003:099A:610C.0003/input/input3
    [  150.047646] hid-generic 0003:099A:610C.0003: input: USB HID v1.00 Keyboard [  USB Multimedia Keyboard ] on usb-xhci-hcd.0.auto-1.2/input0                    
    [  150.051421] input:   USB Multimedia Keyboard  as /devices/platform/soc/c9000000.usb/xhci-hcd.0.auto/usb1/1-1/1-1.2/1-1.2:1.1/0003:099A:610C.0004/input/input4
    [  150.111068] hid-generic 0003:099A:610C.0004: input: USB HID v1.00 Device [  USB Multimedia Keyboard ] on usb-xhci-hcd.0.auto-1.2/input1                      
    

    unplug

    [] usb 1-1.2: USB disconnect, device number 4                       
    

    replug keyboard - top right port

    [] usb 1-1.3: new low-speed USB device number 5 using xhci-hcd      
    [] input:   USB Multimedia Keyboard  as /devices/platform/soc/c9000000.usb/xhci-hcd.0.auto/usb1/1-1/1-1.3/1-1.3:1.0/0003:099A:610C.0005/input/input5
    [] hid-generic 0003:099A:610C.0005: input: USB HID v1.00 Keyboard [  USB Multimedia Keyboard ] on usb-xhci-hcd.0.auto-1.3/input0                    
    [] input:   USB Multimedia Keyboard  as /devices/platform/soc/c9000000.usb/xhci-hcd.0.auto/usb1/1-1/1-1.3/1-1.3:1.1/0003:099A:610C.0006/input/input6
    [] hid-generic 0003:099A:610C.0006: input: USB HID v1.00 Device [  USB Multimedia Keyboard ] on usb-xhci-hcd.0.auto-1.3/input1
    <unplug>
    [] usb 1-1.3: USB disconnect, device number 5     
    

    replug keyboard - top left port

    [] usb 1-2: new low-speed USB device number 6 using xhci-hcd        
    [] xhci-hcd xhci-hcd.0.auto: xHCI host controller not responding, assume dead                                                                       
    [] xhci-hcd xhci-hcd.0.auto: HC died; cleaning up                   
    [] usb usb1-port2: couldn't allocate usb_device                    
    [] xhci-hcd xhci-hcd.0.auto: xHCI host not responding to stop endpoint command.                                                                      
    [] xhci-hcd xhci-hcd.0.auto: Host halt failed, -110                 
    [] xhci-hcd xhci-hcd.0.auto: xHCI host controller not responding, assume dead                                                                       
    [] xhci-hcd xhci-hcd.0.auto: HC died; cleaning up                   
    [] usb usb1-port2: couldn't allocate usb_device                     
    [] usb 1-1: USB disconnect, device number 2                         
    

    Conclusion: Top left (closest to Ethernet) port is unusable, I can use the other 3 simultaneously

    Any tips to get output on HDMI?

    (some timestamps removed to make char count)

  • edited January 28

    @aw__ That looks like an old bug that was fixed in preview release 3 or 4. Are you using the latest image?

  • top left port was my wifi usb can't type login problem with image 7 , using the other 3
    it works

  • libre@libre-computer:~$ cat /proc/version                                       
    Linux version 4.14.11-g18ced7f2-dirty (root@dxue-thinkpad-x1-carbon) (gcc versio
    n 6.3.1 20170404 (Linaro GCC 6.3-2017.05)) #7 SMP PREEMPT Sat Jan 6 00:30:53 EST 2018                                                                           
    
  • Hi all, I flash this .img with command line dd. I plug the µSd in AML S905X CC. For me : Ubuntu doesn't boot. I have a black screen with a line flashing on the top left in my screen.
    Thx for help.

Sign In or Register to comment.