ROC-RK3328-CC Wifi dongle - Ubuntu 4.4.114 linux-headers???

Just got my board, flashed eMMC (lots of struggles with shorting CLK+GND but finally there, why is it so hard?) and booted!
Now that its up and running, I want to get my wifi dongle running on it. To do that, I just need to build my drivers.....
linux-headers-4.4.114 are nowhere to be found!?!? So when I try to build the driver (for either of my dongles) I get a no-modules found error....

make ARCH=aarch64 CROSS_COMPILE= -C /lib/modules/4.4.114/build M=/home/firefly/EW-7811Un_Linux_driver_v1.0.0.5/RTL8188C_8192C_USB_linux_v4.0.2_9000.20130911/driver/rtl8188C_8192C_usb_linux_v4.0.2_9000.20130911 modules
make[1]: *** /lib/modules/4.4.114/build: No such file or directory. Stop.

Trying apt-cache search linux-headers.4.4.114 and get nothing.... So, just for fun, tried installing the linux-headers-generic and symlinking a 4.4.114 folder to those... more errors. Thankfully didn't brick it! hah..

Does anyone know of a wifi dongle that works with this running Ubuntu Or any suggestions on how to fix my driver conundrum? Maybe another OS would work better?

I was thinking of getting an Edimax EW-7811Un, but tried compiling the drivers before purchasing (thankfully). Also I had a TP-Link TL-WN822N that I also can't build the drivers for... :neutral:


Sign In or Register to comment.