How-To enable the eMMC ?

Hi there
How could i enable the 64gb eMMC for my Board ?
What steps do i have to do to get access to it ?
Greetz from Germany


  • I just found (but haven't used yet) instructions from the Armbian forums, which include how to install to eMMC

  • Using Armbian-config brings up the message on the Tritium ALL-H3-CC of no available target. This despite the fact that the eMMC is installed and working. I know this because if I remove the SDC, from which the unit is operating and then cold boot the unit, I boot into the 'DragonBoard' environment installed on the eMMC now.

    Have other solutions to this been found?

  • The eMMC bindings are not in the device tree in mainline so it has to be added manually. Please create a ticket in the Armbian forum about this.

  • wow! Do you know those manual changes?

  • edited June 2018

    Yeah... about that. Tried following those instructions on a Debian laptop. Can't get sunxi-fel to build properly. Keeps returning a fatal error for the missing 'libusb.h' include, which I have confirmed over and again is present. Tried various adds to the $PATH variable with no luck.

    I put libusb.h in the sunxi-tools/include folder I get a string of errors two pages long with missing usb libraries.

    So at this point, unless somebody comes up with another way to do it, typical users, like myself, are unable to access the eMMC or write a bootable image to it. :-(

  • edited June 2018

    @loverpi said:
    Or even better just use this:

    Some information from is erroneous, or omitted...

    1. The path for libusb.h is not correctly included in the file ../sunxi-tools/fel_lib.c. The easiest fix is to copy libusb.h from its installed location to the include directory in the sunxi-tools directory.

    The following assumes you have followed the instructions to clone the sunxi-tools to your home directory and that you have installed the libusb-1.0-dev.

    sudo cp /user/include/libusb-1.0/libusb.h ~/sunxi-tools/include

    1. If you run "sudo make sunxi-fel" and get a string of errors that include "pkg-config: not found" then you do not have pkg-config installed on your system. To correct this from the command line enter the following:

    sudo apt-get update
    sudo apt-get install pkg-config
    sudo make sunxi-fel

    Bingo! sunxi-fel is compiled!

    1. Connect to the eMMC card on your Libre ALLWINNER-CC-H3 device.
    • Remove the SD Card from the device
    • Do not use the USB mini port to connect the device to the host computer. Use the short USB-A to USB-A cable that was shipped with the eMMC module.
    • Connect one end of the USB-A cable to the top-center USB port on the device. NOTE: I have not tested the other three USB-A ports to see if they work.
    • Carefully hold down the UBOOT button on the device while plugging the other end of the USB-A cable into your Debian machine.
    • Release the UBOOT button. The red LED should remain lighted and solid. The blue and green LEDs should not be blinking.
    • At the Command Prompt on your host machine type the following from the sunxi-tools directory...

    sudo ./sunxi-fel version

    If connection has failed the command will return the line...
    ERROR: Allwinner USB FEL device not found!

    If connection is successful the command will return something similar to...
    AWUSBFEX soc=00001718(H5) 00000001 ver=0001 44 08 scratchpad=00017e00

    Next up... burning a bootable armbian image to the device!

  • @DWheaton55 Thanks for the write-up. Only one of the ports is the OTG port so only the USB port you mentioned will work. Official images are coming soon as well. Waiting for Linux 4.18 to stabilize.

  • There is still a problem, at least one I have yet to resolve. That is that once the Tritium is recognized by Sunxi-fel it remains invisible as a USB, or other storage device to the Debian OS. So I am still unable to write an image to the eMMC.

  • edited June 2018

    This is a significant revision to my earlier post from June 28, 2018.

    The instructions to make the sunxi-tools remain relevant, but the method for accessing the Tritium in 'FEL' mode are much easier.

    Go back to the original site,

    From there download the fel-sdboot.img 2MB file to the desktop of the host computer and then use a tool like Etcher to flash the fel-sdboot.img file to an SD Card.

    Unplug the Tritium unit from your host computer's USB port. Then insert the SD Card into your Tritium device. Plug the Tritium unit back to the host computer's USB port without pressing the UBOOT button. The red LED should light and remain solid with no blinking blue or green LED.

    From the CLI on the host computer run the sunxi-fel command from the root of the sunxi-tools directory.

    sudo ./sunxi-fel --list --verbose

    The connection should be successful as shown above. To further test the connection complete the 'Preparations' section of the instructions to add the UDEV rule. Once that is done reboot the host computer to reload all UDEV rules, including the newly added rule.

    Note: Unplug the Tritium prior to rebooting and then plug it back in after reboot is complete.

    After reboot run the following command:

    The Tritium device with eMMC in flashing mode should show a line similar to:
    Bus 00n Device 00n: ID 1f3a:efe8 Onda (unverified) V972 tablet in flashing mode

  • I have concluded that Sunxi-tools, as used in this thread, will allow the eMMC to be seen by the Armbian build, but not mounted.

    Other posts on the Libre Computer web site, including the eMMC Flashing Guide, make reference to Linux images that are not yet available for the Tritium. The source files for Libre's "lc_distro_transfer" utility are also not available to build for access to the Tritium's onboard eMMC.

    As of now, there is no solution to porting the OS to the eMMC for booting until Libre provides it.

  • Would be nice to see some progress on this? Libre???
  • Agreed Nkfs. The fel-mass-storage information on Github "might" work with an H3 board with eMMC, but I have definitively ruled out any possibility of it working with the H5 SoC.

    I have also joined the Libre Computer FaceBook page and there is no information there about this issue that is useful in resolving the problem.

    The instructions provided for LePotato, which are referred to as a possible solution somewhere else in this forum are a dead end as well. None of the builds available for that platform will boot on the H5 board I have, meaning further implementation of those instructions are equally useless.

    I'm still at the point I was when I posted on July 5th that Libre Computer must provide support in resolving the eMMC issue. Until then the Tritium sits on the bench with nothing to do but wait!

  • So here we are nearly midway through September 2018 and I think everyone who ordered an eMMC with their Tritium boards (H3 or H5) are in the same boat; no way to access the device or make it a useful part of that system.

    When might we expect Libre Computer to resolve this issue?

  • Yes, we would love to see an update on this. Feels like they kind of ignored the tritium platform. Maybe just used it as easy seed-money... Disappointing to say the least.
  • So does the eMMC not get detected correctly on these boards? I was going to order one and noticed in the US, it's not being sold over at Amazon. I was curious as to why and then found this in the forum. Guess I shouldn't be ordering one of these, hey? :)

  • The 4.x eMMC modules will be available in the US in approximately two weeks.

  • @loverpi said:
    The 4.x eMMC modules will be available in the US in approximately two weeks.

    Great! Thanks for letting me know.

Sign In or Register to comment.