Not scanning sda at bootup.

Hi all!
I tried to boot linux form an SDcard, 32bit "standard" Ubuntu image was a no-go (tried different SDcard, no dice) so I moved to a 64 bit image and it worked straight to desktop.
I have an USB3 port and an (old, but fast) 120GB Corsair ForceGT SSD (and the external chassis support UASP too!) so I tried to move linux to that drive.
It wasn't difficoult:
1- I made a partition by partition "copy" of the working SD to another SD, minus the "storage" partition (the fifth).
2- Partitioned the SSD as GPT, made an EXT4 partition, copied fifth SD partition to SSD
3- Fired a blkid, wrote down PARTUUID for that SSD partition
4- Mounted partition 4 from my "hacked" SDcard, edited extlinux/extlinux.conf replacing the old PARTUUID= with the new one.

Now this: bootstrap works, goes all the way up to root mount... and then nothing.
Plugging and unpluging my SSD works, but kernel just don't scan for partitions on USB disks so it just sits there waiting for PARTUUID=a29bd0d9-12 (in my example).

EXT4 IS compiled inside kernel because old partition 5 was EXT4 too so the culprit moves to GPT support, maybe firefly kernel doesn't have boot time GPT support, seems unlikely but that's where I am.
If someone has a clue I'm waiting.

Sign In or Register to comment.