eMMC flashing with rkdeveloptool

I'm trying to flash the Debian 9 image provided by RockChip/Libre Computer to the eMMC on my Renegade board. My desktop machine is running Debian 9 as well. I've been using the instructions here:


The eMMC module is a v5.0 I purchased from Loverpi and came with the USB A to USB A cable. I downloaded, compiled and installed rkdeveloptool from github, connected as per the instructions and ran rkdeveloptool ld:

rkdeveloptool ld
DevNo=1 Vid=0x2207,Pid=0x320c,LocationID=303 Maskrom

So it looks like the board is there and in Maskrom mode. Since the eMMC modules come with an Android image for the Le Potato board you don't have to connect the two test pads on the ROC board to force it into Maskrom apparently.

However, doing anything else to the board in rkdeveloptool just shoots out errors:

rkdeveloptool rci
Read Chip Info failed!

rkdeveloptool td
Test Device failed!

I tried running rkdeveloptool as root with the same results. I also can't seem to find the bootloader image the instructions say I need for a raw image, did they remove that from github? Also tried the other utility (update_tool I think it's called) with the same results.

The board itself runs fine off the microSD card and I can use cfdisk to see the eMMC when it's booted from microSD. From that I'm guessing the parts are all in functioning order. Any ideas?


Sign In or Register to comment.