Ethernet does not work.

edited October 2018 in ROC-RK3328-CC

I don't know what else to do. I was so excited to receive the board in the mail today...

So. Obviously trying out an SD card with the official image first. Ubuntu from Can be found here, and it it probably the same image provided in Firefly's Mediafire page.

I also tried ArchLinux rootfs and the Armbian image. The Ethernet does not work, and it was a major reason for me buying this board. It doesn't even show up as an interface. (ip link will only show local loopback)
The first indication is from u-boot:
Net: No ethernet found.

I have attached the complete log from UART, from ddr to uboot to kernel. After that the UBuntu userspace starts up, obviously with network services hanging since they cannnot connect (NetworkManager and the such)

Here's the log.

Ethernet was mentioned in the kernel log as well. In my Arch rootfs attempt I tried mainline as well, and after those lines I got another one that seems like an error:

rk_gmac-dwmac ff540000.ethernet: stmmac_dvr_probe: MDIO bus (id: 0) registration failed
But since u-boot doesn't see it I doubt it'd get further. Can I fix it somehow?

EDIT: eth0 does show up in the debian image. Armbian works as well. So far it seems that no matter what dtb I try mainline does not want ethernet to work. But at least it works here so it's not a hardware issue.


Sign In or Register to comment.