Debian 9 - 06-Jul-2019 release issue


Just a couple of issues, so far.  Wondering if anybody else is experiencing them and whether anybody has figured out a workaround - I'm getting down to seeing what I can do as well and will post a reply if anything comes up.

- I don't seem to have sound.  Maybe it's been a while, but the last time I used Debian on a machine the sound worked out of the box.
- Dragging windows in LXDE is causing a delay.  Full disclosure here, I'm running from a USB flash stick that purportedly runs at USB 2.0 speeds - I'm leaning toward "storage bottleneck" or "usb bus bottleneck".  Any ideas?  I probably will splash the money on an eMMC storage module though...



Tagged:

Comments

  • I don't have audio via HDMI neither.

    As for dragging windows that tear when moving, by what I understand, the driver (open source) for this Mali 450 GPU is in process. Kernel driver has been approved for kernel 5.2 inclusion. The userspace driver was approved just in April 2019, with some issues yet. This might take some time for open source.

    Later, will try to get proprietary binaries installed to test in Debian.

    Here source on Lima (Open Source) driver being developed for these boards: http://linux-sunxi.org/Mali#Driver

    More info for Debian: https://wiki.debian.org/MaliGraphics
  • The same problem to me, installed debian stretch with lxde desktop, and no audio. When I enter on sound preferences, it says that no sound card present.

  • I don't have audio via HDMI neither.

    Here source on Lima (Open Source) driver being developed for these boards: http://linux-sunxi.org/Mali#Driver

    More info for Debian: https://wiki.debian.org/MaliGraphics
    Any ideas on adapting any of the existing drivers manually? Or is that a square peg in a round hole b/c of the unique hardware?
  • Don't know about that, since im a complete Linux noob but I've found something interesting using this command:
    sudo update-alternatives --install /usr/local/lib/aarch64-linux-gnu/mali mali /opt/libre-computer/model/aml-s805x-ac/mali/lib/aarch64-linux-gnu/gl4es 100
    then:
    sudo update-alternatives --config mali
    which shows the one added earlier for selection, after selection made of the gl4es entry, using
    glxgears 
    works! and window seems GPU acelerated.
    Video here: https://www.reddit.com/r/LaFrite/comments/ccaxpy/ok_something_weird_but_good_im_a_total_linux_noob/?utm_source=share&utm_medium=web2x
  • @djismgaming glxgears should already be accelerated on the regular images. The GPU only supports GL ES 2.0 and not regular GL. The GL4ES module emulates commands in GL that are not in GL ES 2.0. You shouldn't need to do your steps since this should already be enabled. What happens when you run glxgears on a stock machine?

    So glxgears uses OpenGL and es2gears uses OpenGL ES 2.0 (subset). If you run glxgears, it should use GL4ES to emulate GL functions not available in the OpenGL ES 2.0 Mali binary.
  • Quick question: If I install the stock image and then 'apt update' & 'apt upgrade' am I messing up the stock image?  Is the image designed to function best stock without upgrading any of the packages?
  • @loverpi

    Please try to, from a default image, run glxgears.

    It does not work without running the command @djismgaming provided.
  • edited July 17
    debian xfce image reimaged to eMMC. Output of glxinfo:

    libre@libre-computer:~$ glxinfo 
    LIBGL: Initialising gl4es
    LIBGL: v1.1.1 built on Jul  6 2019 01:34:51
    LIBGL: Using GLES 2.0 backend
    LIBGL: loaded: libGLESv2.so
    LIBGL: loaded: libEGL.so
    LIBGL: Using GLES 2.0 backend
    LIBGL: Error while gathering supported extension (eglInitialize: EGL_BAD_ALLOC), default to none
    LIBGL: Targeting OpenGL 2.0
    LIBGL: glX Will try to recycle EGL Surface
    LIBGL: Current folder is:/home/libre
    name of display: :0.0
    LIBGL: ERROR: EGL Error detected: EGL_BAD_ALLOC
    LIBGL: Unable to initialize EGL display.
    LIBGL: Unable to initialize EGL.
    LIBGL: ERROR: EGL Error detected: EGL_BAD_ALLOC
    LIBGL: Unable to initialize EGL display.
    LIBGL: Unable to initialize EGL.
    LIBGL: ERROR: EGL Error detected: EGL_BAD_ALLOC
    LIBGL: Unable to initialize EGL display.
    LIBGL: Unable to initialize EGL.
    LIBGL: ERROR: EGL Error detected: EGL_BAD_ALLOC
    LIBGL: Unable to initialize EGL display.
    LIBGL: Unable to initialize EGL.
    LIBGL: ERROR: EGL Error detected: EGL_BAD_ALLOC
    LIBGL: Unable to initialize EGL display.
    LIBGL: Unable to initialize EGL.
    LIBGL: ERROR: EGL Error detected: EGL_BAD_ALLOC
    LIBGL: Unable to initialize EGL display.
    LIBGL: Unable to initialize EGL.
    LIBGL: ERROR: EGL Error detected: EGL_BAD_ALLOC
    LIBGL: Unable to initialize EGL display.
    LIBGL: Unable to init EGL.
    Error: glXCreateContext failed
    LIBGL: ERROR: EGL Error detected: EGL_BAD_ALLOC
    LIBGL: Unable to initialize EGL display.
    LIBGL: Unable to initialize EGL.
    LIBGL: ERROR: EGL Error detected: EGL_BAD_ALLOC
    LIBGL: Unable to initialize EGL display.
    LIBGL: Unable to initialize EGL.

    4 GLX Visuals
        visual  x   bf lv rg d st  colorbuffer  sr ax dp st accumbuffer  ms  cav
      id dep cl sp  sz l  ci b ro  r  g  b  a F gb bf th cl  r  g  b  a ns b eat
    ----------------------------------------------------------------------------
    0x021 24 tc  0  16  0 r  y .   8  8  8  8 .  .  0 32  8  0  0  0  0  0 0 None
    0x022 24 dc  0  16  0 r  y .   8  8  8  8 .  .  0 32  8  0  0  0  0  0 0 None
    0x023 32 tc  0  16  0 r  y .   8  8  8  8 .  .  0 32  8  0  0  0  0  0 0 None
    0x024 32 dc  0  16  0 r  y .   8  8  8  8 .  .  0 32  8  0  0  0  0  0 0 None

    LIBGL: ERROR: EGL Error detected: EGL_BAD_ALLOC
    LIBGL: Unable to initialize EGL display.
    LIBGL: Unable to initialize EGL.
    libre@libre-computer:~$



  • edited July 17
    @loverpi here glxgears on stock image flashed fresh to eMMC:

    libre@libre-computer:~$ glxgears 
    LIBGL: Initialising gl4es
    LIBGL: v1.1.1 built on Jul  6 2019 01:34:51
    LIBGL: Using GLES 2.0 backend
    LIBGL: loaded: libGLESv2.so
    LIBGL: loaded: libEGL.so
    LIBGL: Using GLES 2.0 backend
    LIBGL: Error while gathering supported extension (eglInitialize: EGL_BAD_ALLOC), default to none
    LIBGL: Targeting OpenGL 2.0
    LIBGL: glX Will try to recycle EGL Surface
    LIBGL: Current folder is:/home/libre
    LIBGL: ERROR: EGL Error detected: EGL_BAD_ALLOC
    LIBGL: Unable to initialize EGL display.
    LIBGL: Unable to initialize EGL.
    LIBGL: ERROR: EGL Error detected: EGL_BAD_ALLOC
    LIBGL: Unable to initialize EGL display.
    LIBGL: Unable to init EGL.
    Error: glXCreateContext failed
    libre@libre-computer:~$
    hope this helps
    GPU aceleration is not working for windows on xfce debian at this moment
    windows for file manager / firefox /other apps tear a lot when being moved on the desktop
    haven't tried Ubuntu

  • just my two cents, is this on a 512M or 1G board. Could be the former does not have enough RAM for this. (I've no idea on whether the images are tested on a 512M board, maybe loverpi can tell).
Sign In or Register to comment.