Has anyone installed RetroPie on the LaFrite?

Hello All!!!
I am wondering if anyone has successfully installed RetroPie and if so are there any instructions?

PS:  Please note I have searched the forums and didn't find a discussion.  Also I am an absolute total complete noob when it comes to this stuff

Peace
Phil

Comments

  • edited February 5
    Hi,
    I'm trying to install retropie, but when I try this command
    $ sudo ./retropie_setup.sh
    I get this error:
    Unknown platform - please manually set the __platform variable to one of the following: armv7-mali generic-x11 imx6 odroid-c1 odroid-c2 odroid-xu rpi1 rpi2 rpi3 rpi4 tinker vero4k x86
    And I don't know how to set that variable and which is the correct option for "la frite"
    Anyone has any idea?
    EDITED:
    I've tried this command and now it can launch the retropie main menu:
    sudo __platform=armv7-mali ~/RetroPie-Setup/retropie_setup.sh
    On future posts I will write my advances

  • After trying option 1 from retropie menu (Basic install), I've found a lot of errors with several packages that could not be installed. So, I've tried installing them manually:

    1. sudo apt install libudev-dev libibus-1.0-dev libdbus-1-dev fcitx-libs-dev libsndio-dev libx11-dev libxcursor-dev libxext-dev libxi-dev libxinerama-dev libxkbcommon-dev libxrandr-dev libxss-dev libxt-dev libxv-dev libxxf86vm-dev libgl1-mesa-dev libegl1-mesa-dev libgles2-mesa-dev devscripts debhelper dh-autoreconf libusb-1.0-0-dev  libavcodec-dev libavformat-dev libavdevice-dev mali-fbdev

    2. It gives me ERROR installing mali-fbdev package. Package NOT FOUND
    3. So, I've execute last command without package mali-fbdev. Result OK, NO ERRORS.
    4. I've tried again Retropie Basic Install (first option from Retropie menu). Same result as point 2

    5. CONCLUSION: there's no way to install mali-fbdev package, so it can't be finnished the Retropie installation.

    Any idea?







  • RetroPie is currently all kinds of messed up because of the transition to KMS from legacy Raspberry Pi binaries and mali blobs. Currently working with libretro and RetroPie to use the latest upstream kernel APIs.
  • qu1que said:
    Ok. Thanks for your answer.
    Which OS did you try into? I'm about to try it using Armbian Ubuntu image on it's latest iteration. Sometimes we need to add a package component like non-free or testing into /etc/apt/sources.list 

    For example, I had to add "testing" to the default "main" in Debian 10 in order to install PCSX2 into an Intel Nuc (x64) for use in RetroPie (yesterday) because error log stated that package could not be found to install (PCSX2 is a binary package available in the "testing" component of the Debian repositories. Testing is not available by default on Debian.

    https://wiki.debian.org/SourcesList#Component

    I have yet to try it in Armbian Ubuntu on La Frite.
    Although the compiling should take a lot of time :smiley: I think.
    That's why I'll always wait for the official image from LibreComputer too. But boy have you picked my interest.

    I'll see if I find that package on armbian and report back.
  • edited March 10
    Found these only without modification to sources.list file

    mali-midgard-dkms/bionic,bionic 16.0+pristine-1 all
    mali-t62x-fbdev-driver/bionic 0.1-2 armhf
    mali-t62x-wayland-driver/bionic 0.1-2 armhf
    mali-t62x-x11-driver/bionic 0.1-2 armhf
    mali-t76x-fbdev-driver/bionic 0.1-2 armhf
    mali-t76x-wayland-driver/bionic 0.1-2 armhf
    mali-t76x-x11-driver/bionic 0.1-2 armhf
  • mali-t62x-fbdev-driver
    mali-t76x-fbdev-driver
    These two are the most similar but let me look if I find exactly the one in another component of sources.list
Sign In or Register to comment.