Problem with Kingston DataTraveler SE9 G2 64GB

edited January 10 in AML-S805X-AC
Hello. Is this the right place to report problems?
My La Frite works fine if I use a SanDisk Cruzer 16GB. It has little space and it's slow so I bought a faster Kingston DataTraveler SE9 G2 64GB but it doesn't work right. It starts but it is even slower and after some time I get errors in dmesg like those in the attached files: the first log is from the system still working and the second is after it stopped working. I already updated the firmware to Revision 5 - 2019-09 - u-boot 2019.04 and tried different power supplies, the last one I bought is a 3A for SBC, without success. I'm using ubuntu-bionic-headless-mali-4.19.64+-2019-08-05.
Has anybody any idea of a solution? Thank you in advance

Comments

  • Always stick to SanDisk, Samsung, or Micron memory devices since they make their own memory and controllers. Kingston drives are highly unreliable because they have to make money and use incredibly cheap controllers to build flash drives. They buy flash and flash controllers from unreliable vendors. We had a batch of 20 Kingston flash drives from MicroCenter and they all failed (bad data read back) with minimal write workloads.
    Your errors from dmesg are because the btrfs checksums did not match. The data that was returned by the drive failed to match the expected checksums.
Sign In or Register to comment.