How do I enable UART1 on the Debian 9 Libre image?

Hi Hi once more :)

Is UART1 already enabled in the default device tree on the Debian9 image from the Libre site?

I'm trying to use UART1 to read incoming midi notes:


I can't find anything regarding RK3328, however I do see detailed info on both the RK3399 and RK3128 on enabling them via DTS.


the results of setserial:
$ setserial -g /dev/ttyS*
/dev/ttyS0, UART: unknown, Port: 0x0000, IRQ: 0
/dev/ttyS1, UART: unknown, Port: 0x0000, IRQ: 0
/dev/ttyS2, UART: unknown, Port: 0x0000, IRQ: 0
/dev/ttyS3, UART: unknown, Port: 0x0000, IRQ: 0
/dev/ttyS4, UART: unknown, Port: 0x0000, IRQ: 0

and dmesg|grep uart only shows UART0 being enabled and then disabled:
$ dmesg|grep uart
[    0.000000] bootconsole [uart0] enabled
[    0.000000] Kernel command line: rockchip_jtag earlyprintk=uart8250-32bit,0xff130000 earlycon=uart8250,mmio32,0xff130000 rw root=PARTUUID=b921b045-1d rootwait rootfstype=ext4 init=/sbin/init
[    0.002641] bootconsole [uart0] disabled


could it be as simple as adding an argument to the kernel command line?
Any help on enabling UART1 would be very much appreciated :)

Thanks

Sign In or Register to comment.