SoC boot issues, only green/red lights, nothing else

Hi everyone,
Been using for a while RK3328-CC, but since yesterday I been unable to make it boot.
1. What image are you using?
- Used my own version of vanilla kernel (5.5), but also tried my previous "working" 5.0-rk3328 branch from DenisP (, and Firefly version at 4.4.
2. Where are you getting your image?
- My own image was built by myself from Linux Stable kernel (Grg Kroah-Hartman one).
- DenisP from his github, built by myself, used to work great.
- Firefly 4.4 one using the old (mk-image, mk-kernel...) and new scripts with repo (
3. What is the file name?
Image ?
4. Are you flashing to a MicroSD card or eMMC module?
MicroSD, actually tried two different microSD with same results.
5. If you are not getting video, what tool are you using to flash the image?
I'm not getting anything, no even video signal, just red and green lights and nothing else. For flashing just the 5 partition design (idbloader, uboot, trust, bootfs, rootfs)
6. Been you doing something before?
I been working trying to make USB3 to work using Vanilla and tuning dts files, but I saw at Kernel 5.5 my external hard disk started to present random problems with hard disk (tack sound under USB2), my guess could be USB disk could taking more power than Renegade could provide at that port.
Sadly, on one of those restarts and after installing Firefly kernel + dts, the chip never got back to anything, just red+green lights, no image at HDMI.
7. Is your SoC well fit?
At least I own a case with a good thermal adapter with a fan.

Thanks, and please if you know something else I could try, let me know.


Sign In or Register to comment.