Command to Re-Detect eMMC

edited April 2019 in ALL-H3-CC

echo -n 1c11000.mmc > /sys/bus/platform/drivers/sunxi-mmc/unbind
echo -n 1c11000.mmc > /sys/bus/platform/drivers/sunxi-mmc/bind

We have added a command to the latest images to handle this: lc_redetect_emmc. This is available on the latest images.

ALL-H3-CC is only compatible with Libre Computer eMMC 4.x modules! Libre Computer eMMC 5.x modules do not work with this platform!


  • What does this do? If it enables the eMMC, does it work with the Raspbian image, or another specific image?

  • This unbinds the mmc driver from the mmc address and then rebinds it. This allows you to boot from the MicroSD card without the eMMC attached. You can then attach the eMMC module and run these commands to re-detect the eMMC module.

  • Using the Raspbian image I get the message, Echo: Write Error: no such device

  • edited September 2018

    Here is a bit more information.

    If I go to /sys/bus/platform/drivers/sunxi-mmc there is a device file there named "1c0f000.mmc". When I run the unbind command against it, the H5 board stops responding as though I removed the SD card while the system was on. This tells me that the 1c0f000.mmc device is the SD card.

    There is no corresponding device file named "1c11000.mmc" or other *.mmc files showing in that directory. Therefore, when I run the commands indicated I get the error previously indicated in my earlier message.

    My attempts have included starting the H5 board without the eMMC attached and then attaching it while the board was powered (that was a little scary). Then, I started the board with the eMMC attached. Still no happy as the commands provided return the same error and there remains no "1c11000.mmc" or other *.mmc file in the stated directory.

    Any suggestions?

  • Please wait for the new images. We have finished all the code but the build process for 20 images is slow.

  • None of the images posted today (09-17-2018) for the H5 board work.

    I flashed all three of the images dated 09/16/2018 and the single image dated 09/14/2018 to a working SD card. All four images display an error message and then attempt to boot through the network card, which is not successful because I have no files on my network to be read by the H5 device.

  • @DWheaton55 The new H5 images are uploaded to The H3 images are building now. Start the board without eMMC connected, wait until it is booted up, run lc_redetect_emmc, run lc_distro_transfer.

  • edited September 2018

    Big thumbs up to Libre Computer... the eMMC flashing works and I have imaged it to run with my Tritium H5 successfully!

    For other users...

    After following the instructions to re-detect the eMMC you are instructed to run the command "lc_distro_transfer". The instructions are missing a little information, which I am posting here and on the Libre FaceBook page.

    1. When the eMMC is initially detected it will mount certain partition. In my case, "/dev/mmcblk1p2" and "/dev/mmcblk1p7". Your mounts might be different.

    2. Use sudo lsblk to determine which partitions are mounted and then unmount them using sudo umount /dev/mmcblk1p2, followed by sudo umount /dev/mmcblk1p7. Take note of the master device name, which in my case is "mmcblk1". It is used as the second argument in the distro transfer command. The distro transfer command will not work while any of the eMMC's partitions are mounted.

    3. Once the mounted partitions have been unmounted enter the command to transfer the distro to the eMMC. In my case this was sudo lc_distro_transfer libre-computer/all-h3-cc-h5 /dev/mmcblk1 lc-debian-9-lxde.

    If you enter the sudo lc_distro_transfer command with no arguments it will return the vendor/model information of your device. That is useful for determining the first argument used with the command.

    If you enter the sudo lc_distro_transfer command with the vendor/model and target device, (i.e. /dev/mmcblk1) without identifying the distro to be transferred the command will display a list of available distros to be used in the transfer. Modify your command to include the desired distro to be transferred to the eMMC.

    Final note... the speed of booting from the eMMC is quite impressive! Thanks again Libre Computer for your hard work in making this a reality.

  • Does this work on the Raspbian image? It seems to be detected but the device isn't coming up under /dev. Any ideas?

    root@raspberrypi:/home/pi# ls /sys/bus/platform/drivers/sunxi-mmc/
    1c0f000.mmc bind uevent unbind

    I tried using the unbind/bind sequence mention above but without any luck. Dmesg doesn't show anything related either.

Sign In or Register to comment.