Choosing to boot from eMMC or MicroSD?

Hello, I recently bought an AML-S905X and so far I have mixed feelings about it and that may be in part of Libre and LoveRPi but I am hoping someone can break this down and explain to me as I can't find a post on the following specifics.

With my device (from LoveRPi), I purchased a 16GB eMMC card (from LoveRPi) and have a 32GB Lexar UHS-II MicroSD card to host the OS on, either by dual-booting or using MicroSD to write to eMMC. As far as my understanding goes, this device boots directly to the eMMC module, and if absent, to the MicroSD slot. So far, I am able to write an image to the MicroSD card, and after 1-2min (current bug) the OS boots successfully at painful MicroSD speeds. If both storage mediums are attached, naturally, the eMMC module will boot first.

Here's where I run into an issue... It seems to me if purchasing an eMMC from LoveRPi, you will be required to buy an adapter in order to load an OS onto it. My eMMC module came loaded with something called MBOX which I have no use for, and because the eMMC module came loaded with an OS unbeknown to me it will always take priority over booting MicroSD.

Only solutions I can think of are blanking the eMMC (with adapter) to possibly force MicroSD booting by default, therefore allowing me to install Linux and use commands to manually write to eMMC; Or, use an adapter to write to eMMC directly. Both of these methods require an additional purchase and waiting, where as ODroid boards (only physical example I own) allow you to toggle boot select thus making an adapter only a convenient way to install an OS to eMMC, not the only way. And, as far as I know the U-Boot feature is currently disabled from my digging and testing. I tried using AMLogic USB Burning Tool with no success. I tried two different distros from LoveRPi site and an Armbian image; device is detected when pressing U-Boot button but every image fails with "Parsing Image Failed", and this has occured on three different computers.

If anyone has any solutions or can confirm this I would greatly appreciate this. Thanks!


  • So far I was just able to flash Libreelec (via dd command and Linux) and Android (via Burning tool) successfully. Please have a look to 'Libreelec' & 'Android - Playstore' thread.

  • I got a little busy but did a ton of searching and I don't think you read through my post...

    As per the post above I have been unsuccessful using the Burning Tool to burn any linux.img I have come across, and I do not want to use Android. I am also unable to use any form of flashing (in this case dd) because when booted into the MicroSD's Ubuntu environment I am unable to hot-swap my eMMC module in. Again, that issue is my eMMC taking boot priority. However, if I misunderstood your reply or the thread you are referencing takes this info into account please correct me and elaborate if you could please.

    UPDATE: I have bought an FT232 UART device to try manipulating the U-Boot environment to see if I could force boot the SD card manually, but I am actually unsure of what commands or files I may need to actually configure this thing properly. Again I have interrupted into U-Boot using Ctrl+C at boot time but I dunno what to do now. If I'm onto something here could someone nudge me in the right direction? Thanks again for your time!

  • Also just tried several more images from Libre, Armbian, LoveRPi and Lakka using the Amlogic USB Burning Tool (v2.0.8). So far I have tried several Debian, Ubuntu, and one Android 7.1.1 image; all of these result in a "Parsing Image Failed" error. I am holding the U-Boot button down while plugging in the double-sided USB-A cable, with one end on the top-left USB port (top right corner of Ethernet jack). This was attempted using a Dell laptop, a Lenovo laptop, and a custom desktop. I also believe I am in the correct mode as USB Burning Tool tells me I have a successful connection on HUBx-x, and UART gives me only one line of output: "GXL:BL1:xxxxxx:xxxxxx;FEAT:ADFC318C;POC:2;RCY:0;USB:0;"

    I will keep posting different methods but this has been the most frustrating SBC experience I've had so far and I feel a little duped.. All I want to do is write an image to the eMMC module.

  • Hey Wooty,
    I'm in the exact same situation as you are. I'm able to boot CoreElec from sdcard but whenever I have the EMMC inserted the system boots some ugly @ss android ripoff called mbox.
    I've also tried the amlogic writer tool several times but that fails everytime, although USB is also in the top left and the software sees the board.
    I don't mind buying an extra USB cable to write to the EMMC directly, it's just the wait. And then again the extra cable shouldn't be necessary,why else delivery a USB cable with the EMMC? Also I'm unable to find the USB cable, to write to EMMC directly, in the loverpi store. While if I'm not mistaken it was there when I purchased the board. It also seems that EMMC cards do not have a universal layout which means a cable purchased in another store might not work.
    It's unfortunate that this forum is not that active as I'm sure we aren't the first ones to come across this.
    If you come across a solution that let's you write an OS to the EMMC please post it, I'll do the same.
    Cheers Ronald
  • The default boot order is eMMC and then SD card. The u-boot button is for plugging an Android firmware update image into the OTG port and triggering the upgrade mechanism. There would need to be logic added to the Android image to switch boot devices.

  • I can connect to LePotate using Amlogic USB Burning tool(2.1.6), Keep pushing u-boot button, and connect USB Cable. USB Burning tool say 'Connect Success'.

    But, I Import image, Tool say 'Parse burnning image fail'. I tried following images,

    • Lakka-S905.arm-2.1-LePotate.img
    • LibreELEC-S905.arm-8.2-
    • CoreELEC-S905.arm-8.95.1.img
    • CoreELEC-LePotate.arm-8.95.1.img

    These image was downloaded from .

    Where is correct image ?
    What is correct procedure?

  • Those images are for burning to the MicroSD card. They are not designed for eMMC.

  • edited September 2018

    @nasobeme said:
    Oh, I see. so, where is image for eMMC ?

    There isn't any. Even if there were, the EMMC module is useless until they make an external plug-in board to write an image from a PC' usb port, which may never happen :( . Just get a U3 rated uSD card. Incidentally, if you are trying to use the AML Burning Tool, there is an option to bypass the image check on the menus. But that check seems to be permanently enabled. I even tried scanning the binary executable to see if there was an override enbedded. No luck there either. At this point I'm just writing off the EMMC is as a complete loss/duped purchase >:) .

  • There is a project to develop a new tool that is not AMLBurningTool. Libre Computer is working on tooling to unify flashing on Tritium and Le Potato. Run the tool, plug in the board with eMMC attached and u-boot button held down, and write image to eMMC as if it was a flash drive. No separate reader required. The internal command line version works.

  • edited September 2018

    I understand that there is not Image for emmc.
    But, I read following document,

    In this document, how to flash using command line tool 'lc_distro_transfer'.
    I know that this document is partially incorrect. It show boot priority is 'SD EMMC'. it is not correct.
    Is this command line tool 'new tool that is no AMLBurningTool' ?

  • edited September 2018

    That tool flashes the MicroSD card operating system factory state to eMMC. The issue is that the bootloader for eMMC is different than that of the MicroSD card.

  • way I found till they get tool done was use a ROC-3328 board as adaptor
    and Gnome disc utilty to flash image

  • edited January 2019

    I have revisited this and found this post, glad someone from the team cared enough to update this thread... ... Not!

    Still a horrible solution, definitely not for beginners, but I will try this and post updated results in case others stumble across this thread.

Sign In or Register to comment.